aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-04-22 16:42:41 -0400
committerDavid Robillard <d@drobilla.net>2022-04-23 21:18:56 -0400
commitadc8d07a210adcea86024121b53f28170141dae4 (patch)
tree32e7ac406504eea060456261bad8223cc7c706e2 /meson.build
parentc7c45e1b7b32cb8a9cab173138e9ab7dedff2b12 (diff)
downloadpugl-adc8d07a210adcea86024121b53f28170141dae4.tar.gz
pugl-adc8d07a210adcea86024121b53f28170141dae4.tar.bz2
pugl-adc8d07a210adcea86024121b53f28170141dae4.zip
Move reserved platform defines from code to build system
Numerous things warn about this, and it's generally a bad idea to put these in the code since it can result in incompatibly compiled code being linked together. Unfortunately this makes building manually (without the build system) more fiddly, but such is life.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 8f7d3b0..9530cbf 100644
--- a/meson.build
+++ b/meson.build
@@ -45,7 +45,6 @@ if get_option('strict')
'-Wno-documentation', # Cairo
'-Wno-documentation-unknown-command', # Cairo
'-Wno-padded',
- '-Wno-reserved-id-macro',
'-Wno-reserved-identifier', # Cairo, FD_ZERO
'-Wno-switch-default',
'-Wno-switch-enum',
@@ -180,6 +179,7 @@ elif host_machine.system() == 'windows'
else # X11
x11_dep = cc.find_library('X11')
+ core_args += '-D_POSIX_C_SOURCE=200809L'
xcursor_dep = cc.find_library('Xcursor', required: false)
if xcursor_dep.found()