aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2021-03-10 14:20:13 -0500
committerDavid Robillard <d@drobilla.net>2021-03-10 14:20:13 -0500
commitefe19ede5f5371fbece1c9283fc499f5f97eaaae (patch)
tree1dd0af5795e1abd149b8b922b00a30504e7611e0 /meson.build
parent9939cb9bf04d9997c1cf5d87bf6260ab21d25272 (diff)
downloadpugl-efe19ede5f5371fbece1c9283fc499f5f97eaaae.tar.gz
pugl-efe19ede5f5371fbece1c9283fc499f5f97eaaae.tar.bz2
pugl-efe19ede5f5371fbece1c9283fc499f5f97eaaae.zip
Fix warnings with VS2019
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 0b7b9fa..02fae17 100644
--- a/meson.build
+++ b/meson.build
@@ -64,15 +64,16 @@ if get_option('strict')
]
elif cc.get_id() == 'msvc'
c_warnings += [
- '/wd4061', # enumerator in switch is not explicitly handled
'/wd4028', # formal parameter different from declaration
+ '/wd4061', # enumerator in switch is not explicitly handled
'/wd4191', # unsafe conversion from type to type
- '/wd4996', # function or variable may be unsafe
'/wd4514', # unreferenced inline function has been removed
'/wd4706', # assignment within conditional expression
'/wd4710', # function not inlined
'/wd4711', # function selected for automatic inline expansion
+ '/wd4800', # implicit conversion from int to bool
'/wd4820', # padding added after construct
+ '/wd4996', # function or variable may be unsafe
'/wd5045', # will insert Spectre mitigation for memory load
]
endif
@@ -119,6 +120,7 @@ if get_option('strict')
'/wd4706', # assignment within conditional expression
'/wd4710', # function not inlined
'/wd4711', # function selected for automatic inline expansion
+ '/wd4800', # implicit conversion from int to bool
'/wd4820', # padding added after construct
'/wd4868', # compiler may not enforce left-to-right evaluation order
'/wd4996', # function or variable may be unsafe