aboutsummaryrefslogtreecommitdiffstats
path: root/bindings/cpp/test/headers/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'bindings/cpp/test/headers/meson.build')
-rw-r--r--bindings/cpp/test/headers/meson.build33
1 files changed, 33 insertions, 0 deletions
diff --git a/bindings/cpp/test/headers/meson.build b/bindings/cpp/test/headers/meson.build
new file mode 100644
index 0000000..67dad3c
--- /dev/null
+++ b/bindings/cpp/test/headers/meson.build
@@ -0,0 +1,33 @@
+# Copyright 2020-2025 David Robillard <d@drobilla.net>
+# SPDX-License-Identifier: 0BSD OR ISC
+
+header_cpp_suppressions = []
+
+if get_option('warning_level') == 'everything'
+ if cc.get_id() == 'clang'
+ if not meson.is_cross_build()
+ header_cpp_suppressions += ['-Wno-poison-system-directories']
+ endif
+ endif
+endif
+
+test_headers_cpp_args = header_cpp_suppressions
+test_headers_cpp_args += [
+ '-DPUGL_NO_INCLUDE_GL_H',
+ '-DPUGL_NO_INCLUDE_GLU_H',
+]
+
+if vulkan_dep.found()
+ test_headers_cpp_args += ['-DPUGL_TEST_VULKAN']
+endif
+
+test(
+ 'headers',
+ executable(
+ 'test_headers_cpp',
+ files('test_headers.cpp'),
+ cpp_args: test_headers_cpp_args,
+ dependencies: puglpp_dep,
+ ),
+ suite: 'unit',
+)