aboutsummaryrefslogtreecommitdiffstats
path: root/doc/cpp/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'doc/cpp/meson.build')
-rw-r--r--doc/cpp/meson.build10
1 files changed, 4 insertions, 6 deletions
diff --git a/doc/cpp/meson.build b/doc/cpp/meson.build
index ec67d39..559362d 100644
--- a/doc/cpp/meson.build
+++ b/doc/cpp/meson.build
@@ -28,9 +28,8 @@ subdir('xml')
subdir('api')
docs = custom_target(
- 'singlehtml C++ documentation for pugl',
- command: [sphinx_build, '-M', 'singlehtml',
- meson.current_build_dir(), meson.current_build_dir(),
+ 'singlehtml',
+ command: [sphinx_build, '-M', 'singlehtml', '@OUTDIR@', '@OUTDIR@',
'-E', '-q', '-t', 'singlehtml'],
input: [cpp_rst_files, cpp_pugl_rst, cpp_index_xml],
output: 'singlehtml',
@@ -39,9 +38,8 @@ docs = custom_target(
install_dir: docdir / 'puglpp-0')
docs = custom_target(
- 'html C++ documentation for pugl',
- command: [sphinx_build, '-M', 'html',
- meson.current_build_dir(), meson.current_build_dir(),
+ 'html',
+ command: [sphinx_build, '-M', 'html', '@OUTDIR@', '@OUTDIR@',
'-E', '-q', '-t', 'html'],
input: [cpp_rst_files, cpp_pugl_rst, cpp_index_xml],
output: 'html',