aboutsummaryrefslogtreecommitdiffstats
path: root/examples/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/examples/meson.build b/examples/meson.build
index aa04e80..0c4f998 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -61,6 +61,13 @@ if get_option('warning_level') == 'everything' and is_variable('cpp')
'-Wno-old-style-cast',
'-Wno-switch-enum',
]
+ if host_machine.system() == 'windows'
+ example_cpp_args += [
+ '-Wno-deprecated-declarations',
+ '-Wno-format-nonliteral',
+ '-Wno-nonportable-system-include-path',
+ ]
+ endif
elif cpp.get_id() == 'gcc'
example_cpp_args += [
'-Wno-effc++',