aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 0c43e1a..e82dec4 100644
--- a/meson.build
+++ b/meson.build
@@ -8,6 +8,7 @@ project(
'b_ndebug=if-release',
'buildtype=release',
'c_std=c99',
+ 'c_winlibs=',
'cpp_std=c++14',
],
license: 'ISC',
@@ -162,10 +163,11 @@ elif host_machine.system() == 'windows'
user32_dep = cc.find_library('user32')
shlwapi_dep = cc.find_library('shlwapi')
dwmapi_dep = cc.find_library('dwmapi')
+ gdi32_dep = cc.find_library('gdi32')
platform = 'win'
platform_sources = files('src/win.c')
- core_deps = [user32_dep, shlwapi_dep, dwmapi_dep]
+ core_deps = [user32_dep, shlwapi_dep, dwmapi_dep, gdi32_dep]
extension = '.c'
soversion = ''