aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index 791cf04..c47d3ee 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -208,6 +208,13 @@ elif is_variable('cpp')
'-Wno-switch-enum',
'-Wno-unused-macros', # Mac
]
+ if host_machine.system() == 'windows'
+ cpp_unified_args += [
+ '-Wno-cast-function-type',
+ '-Wno-deprecated-declarations',
+ '-Wno-nonportable-system-include-path',
+ ]
+ endif
elif cpp.get_id() == 'gcc'
cpp_unified_args += [
'-Wno-conditionally-supported',