aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index 340a7dd..47ef87f 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -2,15 +2,23 @@ basic_tests = [
'realize',
'redisplay',
'show_hide',
+ 'size',
+ 'strerror',
'stub_hints',
'timer',
'update',
+ 'view',
+ 'world',
]
gl_tests = [
'gl_hints'
]
+cairo_tests = [
+ 'cairo'
+]
+
includes = [
'.',
'../include',
@@ -31,3 +39,12 @@ if opengl_dep.found()
dependencies: [pugl_dep, gl_backend_dep]))
endforeach
endif
+
+if cairo_dep.found()
+ foreach test : cairo_tests
+ test(test,
+ executable('test_' + test, 'test_@0@.c'.format(test),
+ include_directories: include_directories(includes),
+ dependencies: [pugl_dep, cairo_backend_dep]))
+ endforeach
+endif