summaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-05-02 17:34:47 -0400
committerDavid Robillard <d@drobilla.net>2023-05-02 17:35:11 -0400
commit59ae4ffb41e381f794251297e46ffaaaad74840e (patch)
tree95f6e60bbf8e40e5032b0e38ff70da0ed6958a74 /test/meson.build
parentb50503cd1d83c1fadb18a54610515e0e6e6b9429 (diff)
downloadraul-59ae4ffb41e381f794251297e46ffaaaad74840e.tar.gz
raul-59ae4ffb41e381f794251297e46ffaaaad74840e.tar.bz2
raul-59ae4ffb41e381f794251297e46ffaaaad74840e.zip
Fix warning_level=everything on MacOS
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index ce9dd49..b7b3ce4 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -38,6 +38,12 @@ if cpp.get_id() == 'clang'
'-Wno-weak-vtables',
]
+ if not meson.is_cross_build()
+ header_args += [
+ '-Wno-poison-system-directories',
+ ]
+ endif
+
if host_machine.system() == 'windows'
header_args += [
'-Wno-nonportable-system-include-path',