summaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-05-02 12:31:15 -0400
committerDavid Robillard <d@drobilla.net>2023-05-02 13:34:31 -0400
commitb23035e1706d1a828e7698abcc76cdac37e92b72 (patch)
treefcb7a867e363c9ac818e55aa5bf1f5741bde872a /test/meson.build
parent32a95bd5024623befa3ed445400075a6faae7522 (diff)
downloadraul-b23035e1706d1a828e7698abcc76cdac37e92b72.tar.gz
raul-b23035e1706d1a828e7698abcc76cdac37e92b72.tar.bz2
raul-b23035e1706d1a828e7698abcc76cdac37e92b72.zip
Replace strict option with new meson warning level
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/test/meson.build b/test/meson.build
index 0c073b8..ce9dd49 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -1,7 +1,7 @@
# Copyright 2019-2022 David Robillard <d@drobilla.net>
# SPDX-License-Identifier: 0BSD OR GPL-3.0-or-later
-if get_option('strict')
+if get_option('lint')
if not meson.is_subproject()
# Check release metadata
autoship = find_program('autoship', required: get_option('tests'))
@@ -33,6 +33,7 @@ header_args = []
if cpp.get_id() == 'clang'
header_args += [
'-Wno-c++17-extensions',
+ '-Wno-c++98-compat',
'-Wno-padded',
'-Wno-weak-vtables',
]
@@ -54,6 +55,10 @@ elif cpp.get_id() == 'gcc'
elif cpp.get_id() == 'msvc'
header_args += [
+ '/experimental:external',
+ '/external:W0',
+ '/external:anglebrackets',
+
'/wd4626', # assignment operator implicitly deleted
'/wd5027', # move assignment operator implicitly deleted
'/wd5262', # implicit fall-through