aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-03-31 17:17:41 -0400
committerDavid Robillard <d@drobilla.net>2023-12-02 18:49:08 -0500
commitb5956c4dc6b065d664908104d5fc6752a87e3364 (patch)
tree6be1fa515891e759092bb9bea082e27c78bfb6de /meson.build
parent439d6ec3d6dfbea74334beace790f500e61c9b7d (diff)
downloadserd-b5956c4dc6b065d664908104d5fc6752a87e3364.tar.gz
serd-b5956c4dc6b065d664908104d5fc6752a87e3364.tar.bz2
serd-b5956c4dc6b065d664908104d5fc6752a87e3364.zip
Add model and serd-sort utility
With all the new functionality, the complexity of the serd-pipe command-line interface is starting to push the limits of available flags. So, instead of grafting on further options to control a model, this commit adds a new tool, serd-sort, which acts somewhat like a stripped-down serd-pipe that stores statements in a model in memory. This keeps the complexity (including the user-facing complexity) of any one tool down, since other more focused tools can be used for streaming tasks in a pipeline. In other words, abandon Swissarmyknifeism, take a page from the Unix philosophy, and try to expose the model functionality to the command-line in a dedicated focused tool. The model implementation is tested by using this tool to run a subset of the usual test suites, and a special suite to test statement sorting.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 96fb60d1..37330570 100644
--- a/meson.build
+++ b/meson.build
@@ -131,12 +131,16 @@ c_headers = files(
'include/serd/buffer.h',
'include/serd/canon.h',
'include/serd/caret.h',
+ 'include/serd/cursor.h',
+ 'include/serd/describe.h',
'include/serd/env.h',
'include/serd/event.h',
'include/serd/filter.h',
'include/serd/input_stream.h',
+ 'include/serd/inserter.h',
'include/serd/log.h',
'include/serd/memory.h',
+ 'include/serd/model.h',
'include/serd/node.h',
'include/serd/node_syntax.h',
'include/serd/nodes.h',
@@ -164,11 +168,16 @@ sources = files(
'src/byte_source.c',
'src/canon.c',
'src/caret.c',
+ 'src/compare.c',
+ 'src/cursor.c',
+ 'src/describe.c',
'src/env.c',
'src/filter.c',
'src/input_stream.c',
+ 'src/inserter.c',
'src/log.c',
'src/memory.c',
+ 'src/model.c',
'src/node.c',
'src/node_syntax.c',
'src/nodes.c',