aboutsummaryrefslogtreecommitdiffstats
path: root/test/lint/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2025-01-19 22:30:31 -0500
committerDavid Robillard <d@drobilla.net>2025-01-19 22:30:31 -0500
commit40cf01fefae08c4d750e3c42e3aaede9293ea881 (patch)
tree3830f5b2d843ac0691efbca0e32a2ebf63e837ca /test/lint/meson.build
parentd969f9df4ce82739b14404824cde55ba60f3bf5a (diff)
downloadserd-40cf01fefae08c4d750e3c42e3aaede9293ea881.tar.gz
serd-40cf01fefae08c4d750e3c42e3aaede9293ea881.tar.bz2
serd-40cf01fefae08c4d750e3c42e3aaede9293ea881.zip
Fix building lint tests when serdi is unavailable
Diffstat (limited to 'test/lint/meson.build')
-rw-r--r--test/lint/meson.build18
1 files changed, 10 insertions, 8 deletions
diff --git a/test/lint/meson.build b/test/lint/meson.build
index b89af7d7..7e024cb5 100644
--- a/test/lint/meson.build
+++ b/test/lint/meson.build
@@ -94,14 +94,16 @@ if pylint.found()
endif
# Check Turtle formatting with serdi
-foreach ttl_file_path : ttl_metadata_file_paths
- test(
- ttl_file_path.substring(3).underscorify(),
- check_formatting_py,
- args: [files(ttl_file_path), serdi, '-o', 'turtle'],
- suite: 'data',
- )
-endforeach
+if is_variable('serdi')
+ foreach ttl_file_path : ttl_metadata_file_paths
+ test(
+ ttl_file_path.substring(3).underscorify(),
+ check_formatting_py,
+ args: [files(ttl_file_path), serdi, '-o', 'turtle'],
+ suite: 'data',
+ )
+ endforeach
+endif
if not meson.is_subproject()
# Check release metadata