aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-03-27 19:14:40 -0400
committerDavid Robillard <d@drobilla.net>2023-12-02 18:49:08 -0500
commit959a0db69fa0a61b8a131ee49f9a553f0e01f3e1 (patch)
treec57d91a0bee4ab8ae998ec355d612a583e8d6512 /test/meson.build
parent0e9169e24fcfc4599a62f85991f407f257fec520 (diff)
downloadserd-959a0db69fa0a61b8a131ee49f9a553f0e01f3e1.tar.gz
serd-959a0db69fa0a61b8a131ee49f9a553f0e01f3e1.tar.bz2
serd-959a0db69fa0a61b8a131ee49f9a553f0e01f3e1.zip
Add base URI command-line option
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index 2178ce1f..3af7cd15 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -16,6 +16,7 @@ simple_script_paths = [
'../scripts/check_formatting.py',
'serd_test_util/__init__.py',
'run_suite.py',
+ 'test_base.py',
'test_empty.py',
'test_quiet.py',
'test_stdin.py',
@@ -172,6 +173,8 @@ endif
simple_command_tests = {
'pipe': {
'bad': [
+ ['-B', 'nonuriorpath'],
+ ['-B'],
['-c'],
['-fi'],
['-i', 'turtle'],
@@ -223,6 +226,18 @@ if is_variable('serd_pipe')
test('none', serd_pipe, env: test_env, should_fail: true, suite: cmd_suite)
+ # Base URI options
+
+ test(
+ 'base',
+ files('test_base.py'),
+ args: pipe_script_args,
+ env: test_env,
+ suite: cmd_suite,
+ )
+
+ # Log
+
test(
'quiet',
files('test_quiet.py'),