aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index 2178ce1f..3af7cd15 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -16,6 +16,7 @@ simple_script_paths = [
'../scripts/check_formatting.py',
'serd_test_util/__init__.py',
'run_suite.py',
+ 'test_base.py',
'test_empty.py',
'test_quiet.py',
'test_stdin.py',
@@ -172,6 +173,8 @@ endif
simple_command_tests = {
'pipe': {
'bad': [
+ ['-B', 'nonuriorpath'],
+ ['-B'],
['-c'],
['-fi'],
['-i', 'turtle'],
@@ -223,6 +226,18 @@ if is_variable('serd_pipe')
test('none', serd_pipe, env: test_env, should_fail: true, suite: cmd_suite)
+ # Base URI options
+
+ test(
+ 'base',
+ files('test_base.py'),
+ args: pipe_script_args,
+ env: test_env,
+ suite: cmd_suite,
+ )
+
+ # Log
+
test(
'quiet',
files('test_quiet.py'),