summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2024-03-14 14:12:24 -0400
committerDavid Robillard <d@drobilla.net>2024-03-14 14:12:24 -0400
commit045b0389fc720608b57fa5243331e1d5a5eabece (patch)
tree5eebbc679270d0067746c18651de8d530d2b3fba /meson.build
parent2c5df8b2164c25bd4577c49eb5830192cdd127e0 (diff)
downloadsord-045b0389fc720608b57fa5243331e1d5a5eabece.tar.gz
sord-045b0389fc720608b57fa5243331e1d5a5eabece.tar.bz2
sord-045b0389fc720608b57fa5243331e1d5a5eabece.zip
Add option to install tool man pagesHEADmaster
Fix some strange redundant installation bug in the process.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 3 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 91b1eb9..e4579d2 100644
--- a/meson.build
+++ b/meson.build
@@ -150,9 +150,8 @@ if not get_option('tools').disabled()
meson.override_find_program('sord_validate', sord_validate)
endif
- if not get_option('docs').disabled()
- install_man(files('doc/sordi.1'))
- install_man(files('doc/sord_validate.1'))
+ if not get_option('man').disabled()
+ install_man(files('doc/sord_validate.1', 'doc/sordi.1'))
endif
endif
@@ -195,6 +194,4 @@ if not get_option('tests').disabled()
subdir('test')
endif
-if not get_option('docs').disabled()
- subdir('doc')
-endif
+subdir('doc')