summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-10-07 12:07:51 -0400
committerDavid Robillard <d@drobilla.net>2022-10-07 12:45:40 -0400
commit67bcd63bda9d7b095489a09b9880aa730ddb5488 (patch)
treefc91ee0cb0cbda396faa742f64b52abc831e1f84 /meson.build
parentd877d78c98d90fbf57136bb73919524e618fd859 (diff)
downloadsord-67bcd63bda9d7b095489a09b9880aa730ddb5488.tar.gz
sord-67bcd63bda9d7b095489a09b9880aa730ddb5488.tar.bz2
sord-67bcd63bda9d7b095489a09b9880aa730ddb5488.zip
Port sord_validate to pcre2
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 669e180..2bfd814 100644
--- a/meson.build
+++ b/meson.build
@@ -117,14 +117,14 @@ if not get_option('tools').disabled()
meson.override_find_program('sordi', sordi)
- pcre_dep = dependency('libpcre', required: false)
+ pcre2_dep = dependency('libpcre2-8', required: false)
- if pcre_dep.found()
+ if pcre2_dep.found()
sord_validate = executable('sord_validate',
files('src/sord_validate.c'),
c_args: c_suppressions,
install: true,
- dependencies: [sord_dep, pcre_dep])
+ dependencies: [sord_dep, pcre2_dep])
meson.override_find_program('sord_validate', sord_validate)
endif