summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2025-01-20 12:56:42 -0500
committerDavid Robillard <d@drobilla.net>2025-01-20 12:58:37 -0500
commitd8499db010b1e42ebd14f2f2900db59200f61dc1 (patch)
tree0858c32309ab44d5dd8f83e9f502674a325fa9d3 /meson.build
parent5edcf18adfbc4240040c667c00884cbd049e3a84 (diff)
downloadsord-d8499db010b1e42ebd14f2f2900db59200f61dc1.tar.gz
sord-d8499db010b1e42ebd14f2f2900db59200f61dc1.tar.bz2
sord-d8499db010b1e42ebd14f2f2900db59200f61dc1.zip
Use "system" include type for all dependencies and add header test
Things get confused when these flags differ across projects, so universally use "system" for external dependencies and test for header warnings only in the project that owns them.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 34f15fb..f99439c 100644
--- a/meson.build
+++ b/meson.build
@@ -11,7 +11,7 @@ project(
],
license: 'ISC',
meson_version: '>= 0.56.0',
- version: '0.16.18',
+ version: '0.16.19',
)
sord_src_root = meson.current_source_dir()
@@ -136,8 +136,8 @@ c_suppressions = cc.get_supported_arguments(c_suppressions)
m_dep = cc.find_library('m', required: false)
-zix_dep = dependency('zix-0', version: '>= 0.4.0')
-serd_dep = dependency('serd-0', version: '>= 0.30.10')
+zix_dep = dependency('zix-0', include_type: 'system', version: '>= 0.4.0')
+serd_dep = dependency('serd-0', include_type: 'system', version: '>= 0.30.10')
##########################
# Platform Configuration #