summaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-09-01 19:21:59 -0400
committerDavid Robillard <d@drobilla.net>2022-09-01 19:21:59 -0400
commit70b16298f30c8ca91032abbadead945f6ce8fa07 (patch)
tree3c0ac0959aa236d39dac6fdbc296e379df3a4d53 /test/meson.build
parent53f071a571899faf27dd730ea24838c16887836c (diff)
downloadsord-70b16298f30c8ca91032abbadead945f6ce8fa07.tar.gz
sord-70b16298f30c8ca91032abbadead945f6ce8fa07.tar.bz2
sord-70b16298f30c8ca91032abbadead945f6ce8fa07.zip
Adopt REUSE machine-readable licensing standard
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build35
1 files changed, 27 insertions, 8 deletions
diff --git a/test/meson.build b/test/meson.build
index 551f44f..9979e2e 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -1,3 +1,30 @@
+# Copyright 2021-2022 David Robillard <d@drobilla.net>
+# SPDX-License-Identifier: CC0-1.0 OR ISC
+
+####################
+# Project Metadata #
+####################
+
+# Check release metadata
+if get_option('strict') and not meson.is_subproject()
+ autoship = find_program('autoship', required: false)
+ if autoship.found()
+ test('autoship', autoship, args: ['test', sord_src_root], suite: 'data')
+ endif
+endif
+
+# Check licensing metadata
+reuse = find_program('reuse', required: false)
+if reuse.found()
+ test('REUSE', reuse,
+ args: ['--root', sord_src_root, 'lint'],
+ suite: 'data')
+endif
+
+##############
+# Unit Tests #
+##############
+
unit_tests = [
'sord',
]
@@ -14,11 +41,3 @@ foreach unit : unit_tests
suite: 'unit',
)
endforeach
-
-if get_option('strict') and not meson.is_subproject()
- # Check release metadata
- autoship = find_program('autoship', required: false)
- if autoship.found()
- test('autoship', autoship, args: ['test', sord_src_root], suite: 'data')
- endif
-endif