summaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build22
1 files changed, 22 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
new file mode 100644
index 0000000..72a4870
--- /dev/null
+++ b/test/meson.build
@@ -0,0 +1,22 @@
+autoship = find_program('autoship', required: false)
+
+unit_tests = [
+ 'sord',
+]
+
+foreach unit : unit_tests
+ test(
+ unit,
+ executable(
+ 'test_@0@'.format(unit),
+ files('test_@0@.c'.format(unit)),
+ c_args: c_suppressions,
+ dependencies: sord_dep,
+ ),
+ suite: 'unit',
+ )
+endforeach
+
+if autoship.found()
+ test('autoship', autoship, args: ['test', sord_src_root], suite: 'data')
+endif