summaryrefslogtreecommitdiffstats
path: root/doc/c/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2021-01-11 02:45:04 +0100
committerDavid Robillard <d@drobilla.net>2021-03-16 19:06:31 -0400
commit2f2fac062817a6cca82078fc6dcc6401fca3e292 (patch)
tree60eb33ae3d070e487a29b017a713d1b05edf83c7 /doc/c/meson.build
parentc46452c83d442de137fa6470ba544e3ba142e923 (diff)
downloadsratom-2f2fac062817a6cca82078fc6dcc6401fca3e292.tar.gz
sratom-2f2fac062817a6cca82078fc6dcc6401fca3e292.tar.bz2
sratom-2f2fac062817a6cca82078fc6dcc6401fca3e292.zip
WIP: Switch to Meson
Diffstat (limited to 'doc/c/meson.build')
-rw-r--r--doc/c/meson.build42
1 files changed, 42 insertions, 0 deletions
diff --git a/doc/c/meson.build b/doc/c/meson.build
new file mode 100644
index 0000000..eae54dd
--- /dev/null
+++ b/doc/c/meson.build
@@ -0,0 +1,42 @@
+config = configuration_data()
+config.set('SRATOM_VERSION', meson.project_version())
+
+conf_py = configure_file(configuration: config,
+ input: '../conf.py.in',
+ output: 'conf.py')
+
+configure_file(copy: true, input: '../summary.rst', output: 'summary.rst')
+
+c_rst_files = files(
+ 'index.rst',
+ 'overview.rst',
+)
+
+foreach f : c_rst_files
+ configure_file(copy: true, input: f, output: '@PLAINNAME@')
+endforeach
+
+subdir('xml')
+subdir('api')
+
+docs = custom_target(
+ 'singlehtml documentation for sratom',
+ command: [sphinx_build, '-M', 'singlehtml',
+ meson.current_build_dir(), meson.current_build_dir(),
+ '-E', '-q', '-t', 'singlehtml'],
+ input: [c_rst_files, c_sratom_rst, c_index_xml],
+ output: 'singlehtml',
+ build_by_default: true,
+ install: true,
+ install_dir: docdir / versioned_name)
+
+docs = custom_target(
+ 'html documentation for sratom',
+ command: [sphinx_build, '-M', 'html',
+ meson.current_build_dir(), meson.current_build_dir(),
+ '-E', '-q', '-t', 'html'],
+ input: [c_rst_files, c_sratom_rst, c_index_xml],
+ output: 'html',
+ build_by_default: true,
+ install: true,
+ install_dir: docdir / versioned_name)