summaryrefslogtreecommitdiffstats
path: root/doc/c/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-07-03 20:47:34 -0400
committerDavid Robillard <d@drobilla.net>2022-07-18 20:16:10 -0400
commit75e647def0f67647ec7ba1405e26d809a87c62fc (patch)
tree13a73ca75976824ba991c8c7d235830ce663c1e8 /doc/c/meson.build
parented283b838681ed3fb28e94140a6dc5172945776f (diff)
downloadsratom-75e647def0f67647ec7ba1405e26d809a87c62fc.tar.gz
sratom-75e647def0f67647ec7ba1405e26d809a87c62fc.tar.bz2
sratom-75e647def0f67647ec7ba1405e26d809a87c62fc.zip
Switch to meson build system
Diffstat (limited to 'doc/c/meson.build')
-rw-r--r--doc/c/meson.build48
1 files changed, 48 insertions, 0 deletions
diff --git a/doc/c/meson.build b/doc/c/meson.build
new file mode 100644
index 0000000..8ed81c0
--- /dev/null
+++ b/doc/c/meson.build
@@ -0,0 +1,48 @@
+config = configuration_data()
+config.set('SRATOM_VERSION', meson.project_version())
+
+conf_py = configure_file(
+ configuration: config,
+ input: files('../conf.py.in'),
+ output: 'conf.py',
+)
+
+configure_file(
+ copy: true,
+ input: files('../summary.rst'),
+ output: 'summary.rst',
+)
+
+c_rst_files = files(
+ 'index.rst',
+ 'overview.rst',
+)
+
+foreach f : c_rst_files
+ configure_file(copy: true, input: f, output: '@PLAINNAME@')
+endforeach
+
+subdir('xml')
+subdir('api')
+
+docs = custom_target(
+ 'singlehtml',
+ build_by_default: true,
+ command: [sphinx_build, '-M', 'singlehtml', '@OUTDIR@', '@OUTDIR@',
+ '-E', '-q', '-t', 'singlehtml'],
+ input: [c_rst_files, c_sratom_rst, c_index_xml],
+ install: true,
+ install_dir: docdir / 'sratom-0',
+ output: 'singlehtml',
+)
+
+docs = custom_target(
+ 'html',
+ build_by_default: true,
+ command: [sphinx_build, '-M', 'html', '@OUTDIR@', '@OUTDIR@',
+ '-E', '-q', '-t', 'html'],
+ input: [c_rst_files, c_sratom_rst, c_index_xml],
+ install: true,
+ install_dir: docdir / 'sratom-0',
+ output: 'html',
+)