summaryrefslogtreecommitdiffstats
path: root/doc/c/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-09-02 19:00:54 -0400
committerDavid Robillard <d@drobilla.net>2023-09-21 20:16:18 -0400
commit7c8682a1b53713b3263034bc8db3cdb5839968b5 (patch)
treeef495ddf29b53786b57a925bec0a143a0431781b /doc/c/meson.build
parent1d48d40ac4948b1864ca09e9d0a26fdd71bbee8d (diff)
downloadsratom-7c8682a1b53713b3263034bc8db3cdb5839968b5.tar.gz
sratom-7c8682a1b53713b3263034bc8db3cdb5839968b5.tar.bz2
sratom-7c8682a1b53713b3263034bc8db3cdb5839968b5.zip
Clean up documentation and remove junk files from install
Diffstat (limited to 'doc/c/meson.build')
-rw-r--r--doc/c/meson.build53
1 files changed, 0 insertions, 53 deletions
diff --git a/doc/c/meson.build b/doc/c/meson.build
deleted file mode 100644
index 502dd83..0000000
--- a/doc/c/meson.build
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 2021-2022 David Robillard <d@drobilla.net>
-# SPDX-License-Identifier: 0BSD OR ISC
-
-config = configuration_data()
-config.set('SRATOM_VERSION', meson.project_version())
-
-conf_py = configure_file(
- configuration: config,
- input: files('../conf.py.in'),
- output: 'conf.py',
-)
-
-summary_rst = configure_file(
- copy: true,
- input: files('../summary.rst'),
- output: 'summary.rst',
-)
-
-c_rst_files = files(
- 'index.rst',
- 'overview.rst',
-)
-
-sratom_doc_rst_files = [summary_rst] + c_rst_files
-
-foreach f : c_rst_files
- configure_file(copy: true, input: f, output: '@PLAINNAME@')
-endforeach
-
-subdir('xml')
-subdir('api')
-
-docs = custom_target(
- 'singlehtml',
- build_by_default: true,
- command: [sphinx_build, '-M', 'singlehtml', '@OUTDIR@', '@OUTDIR@',
- '-E', '-q', '-t', 'singlehtml'],
- input: [c_rst_files, c_sratom_rst, c_index_xml],
- install: true,
- install_dir: docdir / 'sratom-0',
- output: 'singlehtml',
-)
-
-docs = custom_target(
- 'html',
- build_by_default: true,
- command: [sphinx_build, '-M', 'html', '@OUTDIR@', '@OUTDIR@',
- '-E', '-q', '-t', 'html'],
- input: [c_rst_files, c_sratom_rst, c_index_xml],
- install: true,
- install_dir: docdir / 'sratom-0',
- output: 'html',
-)