summaryrefslogtreecommitdiffstats
path: root/doc/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2021-01-11 02:45:04 +0100
committerDavid Robillard <d@drobilla.net>2021-03-16 19:06:31 -0400
commit2f2fac062817a6cca82078fc6dcc6401fca3e292 (patch)
tree60eb33ae3d070e487a29b017a713d1b05edf83c7 /doc/meson.build
parentc46452c83d442de137fa6470ba544e3ba142e923 (diff)
downloadsratom-2f2fac062817a6cca82078fc6dcc6401fca3e292.tar.gz
sratom-2f2fac062817a6cca82078fc6dcc6401fca3e292.tar.bz2
sratom-2f2fac062817a6cca82078fc6dcc6401fca3e292.zip
WIP: Switch to Meson
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/doc/meson.build b/doc/meson.build
new file mode 100644
index 0000000..81457b9
--- /dev/null
+++ b/doc/meson.build
@@ -0,0 +1,16 @@
+docdir = get_option('datadir') / 'doc'
+
+doxygen = find_program('doxygen', required: get_option('docs'))
+dox_to_sphinx = find_program('../scripts/dox_to_sphinx.py')
+sphinx_build = find_program('sphinx-build', required: get_option('docs'))
+
+build_docs = doxygen.found() and sphinx_build.found()
+
+if build_docs
+ subdir('c')
+endif
+
+if meson.version().version_compare('>=0.53.0')
+ summary('Documentation', build_docs, bool_yn: true)
+endif
+