summaryrefslogtreecommitdiffstats
path: root/doc/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-12-04 19:23:57 -0500
committerDavid Robillard <d@drobilla.net>2022-12-08 19:08:53 -0500
commit95c1033b7c805da8c2bc69f6f43277008a5980b5 (patch)
tree6d5df1465e08970f89cfe363bbbfd4f05ba43e78 /doc/meson.build
parent36fd5599e7c67f9d99046aa1570e7f0d308b7092 (diff)
downloadsratom-95c1033b7c805da8c2bc69f6f43277008a5980b5.tar.gz
sratom-95c1033b7c805da8c2bc69f6f43277008a5980b5.tar.bz2
sratom-95c1033b7c805da8c2bc69f6f43277008a5980b5.zip
Replace duplicated dox_to_sphinx script with sphinxygen dependency
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build9
1 files changed, 7 insertions, 2 deletions
diff --git a/doc/meson.build b/doc/meson.build
index 7e447d5..4bccb1f 100644
--- a/doc/meson.build
+++ b/doc/meson.build
@@ -4,10 +4,15 @@
docdir = get_option('datadir') / 'doc'
doxygen = find_program('doxygen', required: get_option('docs'))
-dox_to_sphinx = files('../scripts/dox_to_sphinx.py')
+sphinxygen = find_program('sphinxygen', required: false)
sphinx_build = find_program('sphinx-build', required: get_option('docs'))
-build_docs = doxygen.found() and sphinx_build.found()
+if not sphinxygen.found()
+ subproject('sphinxygen')
+ sphinxygen = find_program('sphinxygen', required: get_option('docs'))
+endif
+
+build_docs = doxygen.found() and sphinxygen.found() and sphinx_build.found()
if build_docs
subdir('c')