summaryrefslogtreecommitdiffstats
path: root/doc/xml/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-09-02 19:00:54 -0400
committerDavid Robillard <d@drobilla.net>2023-09-21 20:16:18 -0400
commit7c8682a1b53713b3263034bc8db3cdb5839968b5 (patch)
treeef495ddf29b53786b57a925bec0a143a0431781b /doc/xml/meson.build
parent1d48d40ac4948b1864ca09e9d0a26fdd71bbee8d (diff)
downloadsratom-7c8682a1b53713b3263034bc8db3cdb5839968b5.tar.gz
sratom-7c8682a1b53713b3263034bc8db3cdb5839968b5.tar.bz2
sratom-7c8682a1b53713b3263034bc8db3cdb5839968b5.zip
Clean up documentation and remove junk files from install
Diffstat (limited to 'doc/xml/meson.build')
-rw-r--r--doc/xml/meson.build19
1 files changed, 19 insertions, 0 deletions
diff --git a/doc/xml/meson.build b/doc/xml/meson.build
new file mode 100644
index 0000000..119445e
--- /dev/null
+++ b/doc/xml/meson.build
@@ -0,0 +1,19 @@
+# Copyright 2020-2023 David Robillard <d@drobilla.net>
+# SPDX-License-Identifier: 0BSD OR ISC
+
+config = configuration_data()
+config.set('SRATOM_SRCDIR', sratom_src_root)
+config.set('DOX_OUTPUT', meson.current_build_dir() / '..')
+
+c_doxyfile = configure_file(
+ configuration: config,
+ input: files('../Doxyfile.in'),
+ output: 'Doxyfile',
+)
+
+c_index_xml = custom_target(
+ 'index.xml',
+ command: [doxygen, '@INPUT0@'],
+ input: [c_doxyfile] + c_headers,
+ output: 'index.xml',
+)