summaryrefslogtreecommitdiffstats
path: root/test/headers/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2024-10-06 13:35:49 -0400
committerDavid Robillard <d@drobilla.net>2024-10-06 13:35:49 -0400
commita96d07d3610e27abe5fcae72f3b75d639aff57ec (patch)
tree114f1eabb0440dce86433533ce95d8ec28e32914 /test/headers/meson.build
parent6e285c830ac47e7575a4cca2527ba4d6c4a39747 (diff)
downloadsratom-a96d07d3610e27abe5fcae72f3b75d639aff57ec.tar.gz
sratom-a96d07d3610e27abe5fcae72f3b75d639aff57ec.tar.bz2
sratom-a96d07d3610e27abe5fcae72f3b75d639aff57ec.zip
Add clang-format lint test
Diffstat (limited to 'test/headers/meson.build')
-rw-r--r--test/headers/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/test/headers/meson.build b/test/headers/meson.build
index 3796d7f..2e18a44 100644
--- a/test/headers/meson.build
+++ b/test/headers/meson.build
@@ -37,11 +37,13 @@ endif
header_c_suppressions = cc.get_supported_arguments(header_c_suppressions)
+test_headers_source = files('test_headers.c')
+
test(
'headers',
executable(
'test_headers',
- files('test_headers.c'),
+ test_headers_source,
c_args: header_c_suppressions,
dependencies: [sratom_dep],
),