summaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-07-03 20:47:34 -0400
committerDavid Robillard <d@drobilla.net>2022-07-18 20:16:10 -0400
commit75e647def0f67647ec7ba1405e26d809a87c62fc (patch)
tree13a73ca75976824ba991c8c7d235830ce663c1e8 /test/meson.build
parented283b838681ed3fb28e94140a6dc5172945776f (diff)
downloadsratom-75e647def0f67647ec7ba1405e26d809a87c62fc.tar.gz
sratom-75e647def0f67647ec7ba1405e26d809a87c62fc.tar.bz2
sratom-75e647def0f67647ec7ba1405e26d809a87c62fc.zip
Switch to meson build system
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
new file mode 100644
index 0000000..3cecff6
--- /dev/null
+++ b/test/meson.build
@@ -0,0 +1,23 @@
+autoship = find_program('autoship', required: false)
+
+unit_tests = [
+ 'sratom',
+]
+
+foreach unit : unit_tests
+ test(
+ unit,
+ executable(
+ 'test_@0@'.format(unit),
+ files('test_@0@.c'.format(unit)),
+ c_args: c_suppressions,
+ dependencies: [sratom_dep, serd_dep, sord_dep],
+ include_directories: include_directories('../src'),
+ ),
+ suite: 'unit',
+ )
+endforeach
+
+if autoship.found()
+ test('autoship', autoship, args: ['test', sratom_src_root], suite: 'data')
+endif