summaryrefslogtreecommitdiffstats
path: root/test/headers/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/headers/meson.build')
-rw-r--r--test/headers/meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/test/headers/meson.build b/test/headers/meson.build
index 5320627..5cf11a0 100644
--- a/test/headers/meson.build
+++ b/test/headers/meson.build
@@ -8,7 +8,11 @@ if get_option('warning_level') == 'everything'
if not meson.is_cross_build()
c_suppressions += ['-Wno-poison-system-directories']
endif
- endif
+ elif cc.get_id() == 'msvc'
+ header_c_suppressions += [
+ '/wd4820', # padding added after construct
+ ]
+ endif
endif
header_c_suppressions = cc.get_supported_arguments(header_c_suppressions)