summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-08-22 10:40:20 -0400
committerDavid Robillard <d@drobilla.net>2022-08-22 10:40:20 -0400
commit368d712dcccb7b1b5c8dbb96d70165bbab08ec06 (patch)
tree6866aff2393373a3ab90cd3d84270c9ffbe275c5 /meson.build
parent019855506fe2526c7cb192b28be4a65fdc5e9818 (diff)
downloadsuil-368d712dcccb7b1b5c8dbb96d70165bbab08ec06.tar.gz
suil-368d712dcccb7b1b5c8dbb96d70165bbab08ec06.tar.bz2
suil-368d712dcccb7b1b5c8dbb96d70165bbab08ec06.zip
Add autoship test
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index a33859a..b19e5e0 100644
--- a/meson.build
+++ b/meson.build
@@ -320,6 +320,18 @@ if host_machine.system() == 'darwin'
endif
endif
+#########
+# Tests #
+#########
+
+if not meson.is_subproject() and get_option('strict')
+ # Check release metadata
+ autoship = find_program('autoship', required: false)
+ if autoship.found()
+ test('autoship', autoship, args: ['test', suil_src_root], suite: 'data')
+ endif
+endif
+
#################
# Documentation #
#################