summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-05-12 07:34:56 -0400
committerDavid Robillard <d@drobilla.net>2023-05-12 07:34:56 -0400
commit59da01bbc31d2fec5d3fcc87fc87f467b36f9799 (patch)
treed0a3d22017d5754f05a668a7cf24456a809f0ff4 /meson.build
parenta948692dd62bede7babb1b400fb8e91f82b1e92f (diff)
downloadsuil-59da01bbc31d2fec5d3fcc87fc87f467b36f9799.tar.gz
suil-59da01bbc31d2fec5d3fcc87fc87f467b36f9799.tar.bz2
suil-59da01bbc31d2fec5d3fcc87fc87f467b36f9799.zip
Only check for Gtk Quartz support on MacOS
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 9 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 555527c..c490a5f 100644
--- a/meson.build
+++ b/meson.build
@@ -83,11 +83,15 @@ gtk2_x11_dep = dependency(
required: get_option('gtk2').enabled() and get_option('x11').enabled(),
)
-gtk2_quartz_dep = dependency(
- 'gtk+-quartz-2.0',
- include_type: 'system',
- required: get_option('gtk2').enabled() and get_option('cocoa').enabled(),
-)
+if host_machine.system() == 'darwin'
+ gtk2_quartz_dep = dependency(
+ 'gtk+-quartz-2.0',
+ include_type: 'system',
+ required: get_option('gtk2').enabled() and get_option('cocoa').enabled(),
+ )
+else
+ gtk2_quartz_dep = disabler()
+endif
gtk3_dep = dependency(
'gtk+-3.0',