summaryrefslogtreecommitdiffstats
path: root/benchmark/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2024-12-10 16:30:26 -0500
committerDavid Robillard <d@drobilla.net>2024-12-11 00:19:45 -0500
commit54428ad801d32394d2488c54f1887e7fd45c5bc2 (patch)
tree6ae998efaee5c99304db2c298868f499ccc72863 /benchmark/meson.build
parent23cdd12bf40c8128b1c8df9127e5110af89ff460 (diff)
downloadzix-54428ad801d32394d2488c54f1887e7fd45c5bc2.tar.gz
zix-54428ad801d32394d2488c54f1887e7fd45c5bc2.tar.bz2
zix-54428ad801d32394d2488c54f1887e7fd45c5bc2.zip
Clean up platform C flags
Remove platform flags from executable (test program) builds, since they shouldn't be needed there (that being the whole point of a portability library), and replace POSIX flags in WIndows with WIN32_LEAN_AND_MEAN.
Diffstat (limited to 'benchmark/meson.build')
-rw-r--r--benchmark/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/benchmark/meson.build b/benchmark/meson.build
index 3c231c6..bf32b5d 100644
--- a/benchmark/meson.build
+++ b/benchmark/meson.build
@@ -15,7 +15,7 @@ glib_dep = dependency(
if glib_dep.found()
build_benchmarks = true
- benchmark_c_args = platform_c_args
+ benchmark_c_args = extra_c_args
benchmark_c_suppressions = []
if cc.get_id() in ['clang', 'emscripten']