summaryrefslogtreecommitdiffstats
path: root/doc/html/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-05-11 21:00:56 -0400
committerDavid Robillard <d@drobilla.net>2023-05-11 21:00:56 -0400
commit19d6da07a59e6230801fa7ae73b07391f6393098 (patch)
tree161e6775c999d748c3ae54ea3b87cd3cf5992318 /doc/html/meson.build
parent71b215560249747a2f1c3d16f9d372e5b668c45e (diff)
downloadzix-19d6da07a59e6230801fa7ae73b07391f6393098.tar.gz
zix-19d6da07a59e6230801fa7ae73b07391f6393098.tar.bz2
zix-19d6da07a59e6230801fa7ae73b07391f6393098.zip
Clean up reference documentation
Diffstat (limited to 'doc/html/meson.build')
-rw-r--r--doc/html/meson.build30
1 files changed, 30 insertions, 0 deletions
diff --git a/doc/html/meson.build b/doc/html/meson.build
new file mode 100644
index 0000000..7403e95
--- /dev/null
+++ b/doc/html/meson.build
@@ -0,0 +1,30 @@
+# Copyright 2021-2023 David Robillard <d@drobilla.net>
+# SPDX-License-Identifier: 0BSD OR ISC
+
+html_dir = docdir / versioned_name / 'html'
+
+custom_target(
+ 'html',
+ build_by_default: true,
+ command: [
+ sphinx_build, '-M', 'html', '@OUTDIR@' / '..', '@OUTDIR@' / '..',
+ '-t', 'html',
+ ] + sphinx_flags,
+ input: [c_rst_files, c_zix_rst, c_index_xml, conf_py],
+ install: true,
+ install_dir: html_dir,
+ output: [
+ '_static',
+ 'allocation.html',
+ 'api',
+ 'error_handling.html',
+ 'genindex.html',
+ 'index.html',
+ 'string_views.html',
+ 'using_zix.html',
+ ],
+)
+
+if not meson.is_subproject()
+ summary('Paginated HTML', get_option('prefix') / html_dir, section: 'Directories')
+endif