summaryrefslogtreecommitdiffstats
path: root/doc/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-04-02 13:17:46 -0400
committerDavid Robillard <d@drobilla.net>2023-04-02 13:17:46 -0400
commit6dd5d74671f17bf19af4c7070b095073a3239f1b (patch)
tree03dd2fd4654b0e149188abe74371f570b2a90239 /doc/meson.build
parent262d4a1522c38be0588746e874159da5c7bb457d (diff)
downloadzix-6dd5d74671f17bf19af4c7070b095073a3239f1b.tar.gz
zix-6dd5d74671f17bf19af4c7070b095073a3239f1b.tar.bz2
zix-6dd5d74671f17bf19af4c7070b095073a3239f1b.zip
Only load sphinxygen subproject if required tools are found
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build12
1 files changed, 8 insertions, 4 deletions
diff --git a/doc/meson.build b/doc/meson.build
index 4f316a3..2cceed5 100644
--- a/doc/meson.build
+++ b/doc/meson.build
@@ -4,12 +4,16 @@
docdir = get_option('datadir') / 'doc'
doxygen = find_program('doxygen', required: get_option('docs'))
-sphinxygen = find_program('sphinxygen', required: false)
sphinx_build = find_program('sphinx-build', required: get_option('docs'))
-if not sphinxygen.found()
- subproject('sphinxygen')
- sphinxygen = find_program('sphinxygen', required: get_option('docs'))
+if doxygen.found() and sphinx_build.found()
+ sphinxygen = find_program('sphinxygen', required: false)
+ if not sphinxygen.found()
+ subproject('sphinxygen')
+ sphinxygen = find_program('sphinxygen', required: get_option('docs'))
+ endif
+else
+ sphinxygen = disabler()
endif
build_docs = doxygen.found() and sphinxygen.found() and sphinx_build.found()