summaryrefslogtreecommitdiffstats
path: root/doc/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-12-03 16:14:41 -0500
committerDavid Robillard <d@drobilla.net>2022-12-03 16:14:41 -0500
commitc41ebbc08687b5c072108885b7fab66512917d9b (patch)
treeaa6fb2b03623c52842c6ce375fb3d5c8973d6cf7 /doc/meson.build
parent577356481bbcb12468bcf669ef7107dfb057b833 (diff)
downloadzix-c41ebbc08687b5c072108885b7fab66512917d9b.tar.gz
zix-c41ebbc08687b5c072108885b7fab66512917d9b.tar.bz2
zix-c41ebbc08687b5c072108885b7fab66512917d9b.zip
Replace duplicated dox_to_sphinx script with sphinxygen dependency
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build9
1 files changed, 7 insertions, 2 deletions
diff --git a/doc/meson.build b/doc/meson.build
index d0f1952..e08de60 100644
--- a/doc/meson.build
+++ b/doc/meson.build
@@ -4,10 +4,15 @@
docdir = get_option('datadir') / 'doc'
doxygen = find_program('doxygen', required: get_option('docs'))
-dox_to_sphinx = find_program('../scripts/dox_to_sphinx.py')
+sphinxygen = find_program('sphinxygen', required: false)
sphinx_build = find_program('sphinx-build', required: get_option('docs'))
-build_docs = doxygen.found() and sphinx_build.found()
+if not sphinxygen.found()
+ subproject('sphinxygen')
+ sphinxygen = find_program('sphinxygen', required: get_option('docs'))
+endif
+
+build_docs = doxygen.found() and sphinxygen.found() and sphinx_build.found()
if build_docs
# Documentation Code