summaryrefslogtreecommitdiffstats
path: root/doc/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-09-23 16:56:45 -0400
committerDavid Robillard <d@drobilla.net>2023-09-23 16:56:45 -0400
commitf4b2ca45a95399736cba03458cb28958ec4b8379 (patch)
treeaf6e0026c781b1d67a267a827fe09806ab25d515 /doc/meson.build
parentac23e74f8bce3d782fb202e0787bbff737e07733 (diff)
downloadzix-f4b2ca45a95399736cba03458cb28958ec4b8379.tar.gz
zix-f4b2ca45a95399736cba03458cb28958ec4b8379.tar.bz2
zix-f4b2ca45a95399736cba03458cb28958ec4b8379.zip
Clean up sphinx build commands
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/doc/meson.build b/doc/meson.build
index 98cb4af..6d60bbb 100644
--- a/doc/meson.build
+++ b/doc/meson.build
@@ -81,12 +81,14 @@ if build_docs
subdir('api')
# Build strict Sphinx flags, with termination on warnings if werror=true
+ sphinx_in_dir = meson.current_build_dir()
sphinx_flags = ['-E', '-a', '-q']
if get_option('werror')
sphinx_flags += ['-W']
endif
# Run Sphinx to generate final documentation for each format
+ sphinx_build_command = [sphinx_build] + sphinx_flags
foreach format : ['html', 'singlehtml']
if not get_option(format).disabled()
subdir(format)