summaryrefslogtreecommitdiffstats
path: root/doc/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-05-10 16:00:01 -0400
committerDavid Robillard <d@drobilla.net>2023-05-10 16:00:10 -0400
commitff5104de74122477459b48df8b046d06d2db506b (patch)
tree535cfa61fc30068788f1a066339f44b36890f859 /doc/meson.build
parentf9f25a939106febafb238446429b18777f126cdd (diff)
downloadzix-ff5104de74122477459b48df8b046d06d2db506b.tar.gz
zix-ff5104de74122477459b48df8b046d06d2db506b.tar.bz2
zix-ff5104de74122477459b48df8b046d06d2db506b.zip
Build Sphinx documentation in strict mode
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build14
1 files changed, 9 insertions, 5 deletions
diff --git a/doc/meson.build b/doc/meson.build
index 2cceed5..78ed876 100644
--- a/doc/meson.build
+++ b/doc/meson.build
@@ -1,4 +1,4 @@
-# Copyright 2021-2022 David Robillard <d@drobilla.net>
+# Copyright 2021-2023 David Robillard <d@drobilla.net>
# SPDX-License-Identifier: 0BSD OR ISC
docdir = get_option('datadir') / 'doc'
@@ -92,8 +92,10 @@ if build_docs
custom_target(
'singlehtml',
build_by_default: true,
- command: [sphinx_build, '-M', 'singlehtml', '@OUTDIR@', '@OUTDIR@',
- '-t', 'singlehtml'] + sphinx_options,
+ command: [
+ sphinx_build, '-M', 'singlehtml', '@OUTDIR@', '@OUTDIR@',
+ '-W', '-E', '-q', '-t', 'singlehtml',
+ ] + sphinx_options,
input: doc_inputs,
install: true,
install_dir: docdir / versioned_name,
@@ -103,8 +105,10 @@ if build_docs
custom_target(
'html',
build_by_default: true,
- command: [sphinx_build, '-M', 'html', '@OUTDIR@', '@OUTDIR@',
- '-t', 'html'] + sphinx_options,
+ command: [
+ sphinx_build, '-M', 'html', '@OUTDIR@', '@OUTDIR@',
+ '-W', '-E', '-q', '-t', 'html',
+ ] + sphinx_options,
input: doc_inputs,
install: true,
install_dir: docdir / versioned_name,