summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-08-18 16:57:17 -0400
committerDavid Robillard <d@drobilla.net>2022-08-18 16:57:17 -0400
commit0c001d5c7fd4c6c5d9ceeb55ba5fac1780b441af (patch)
tree7e42a1e6ac699fd7c59ad3dfcd4c7c5be2818c75 /meson.build
parentb9d58f74ea1d072e7a2d1c862dc7a1e0fe5fccb0 (diff)
downloadzix-0c001d5c7fd4c6c5d9ceeb55ba5fac1780b441af.tar.gz
zix-0c001d5c7fd4c6c5d9ceeb55ba5fac1780b441af.tar.bz2
zix-0c001d5c7fd4c6c5d9ceeb55ba5fac1780b441af.zip
Fix or remove non-portable features in thread API
Thread function return values are inconsistent between nearly every threading API out there. So, just ignore them entirely, and provide a typedef and sentinel value so user code can be portable.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 2a31887..2f10fbb 100644
--- a/meson.build
+++ b/meson.build
@@ -184,6 +184,7 @@ sequential_tests = [
threaded_tests = [
'test_ring',
'test_sem',
+ 'test_thread',
]
if not get_option('tests').disabled() and not meson.is_subproject()