summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2021-09-10 20:11:47 -0400
committerDavid Robillard <d@drobilla.net>2021-09-10 20:54:28 -0400
commit731ce39ef6fa35f64c19947bdb1719028478fdb9 (patch)
tree87304c55061fc9cd0ab1c3007a78eff44de137dc /meson.build
parent904c1b4d699aeb1ce170f0cd996a01d2d06812e3 (diff)
downloadzix-731ce39ef6fa35f64c19947bdb1719028478fdb9.tar.gz
zix-731ce39ef6fa35f64c19947bdb1719028478fdb9.tar.bz2
zix-731ce39ef6fa35f64c19947bdb1719028478fdb9.zip
Add custom allocator support
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index f732a5f..2da63a0 100644
--- a/meson.build
+++ b/meson.build
@@ -172,6 +172,7 @@ endif
#
sources = [
+ 'src/allocator.c',
'src/bitset.c',
'src/btree.c',
'src/digest.c',
@@ -226,6 +227,7 @@ install_headers(headers, subdir: versioned_name / 'zix')
#
tests = [
+ 'allocator_test',
'bitset_test',
'btree_test',
'digest_test',