summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2024-12-11 10:06:03 -0500
committerDavid Robillard <d@drobilla.net>2024-12-11 10:06:33 -0500
commit8874670463276073fe6cdb0bccd0d9a9a982b4c5 (patch)
tree3a95fee69e627c0bac27206b2db7de1fcf17abc0 /meson.build
parent52048ee6db71982693cdeb603e725a867afd99e5 (diff)
downloadzix-8874670463276073fe6cdb0bccd0d9a9a982b4c5.tar.gz
zix-8874670463276073fe6cdb0bccd0d9a9a982b4c5.tar.bz2
zix-8874670463276073fe6cdb0bccd0d9a9a982b4c5.zip
Fix clang and clang-tidy warnings on Windows
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 96a6d27..d6792f7 100644
--- a/meson.build
+++ b/meson.build
@@ -48,6 +48,7 @@ if cc.get_id() in ['clang', 'emscripten']
if host_machine.system() == 'windows'
c_suppressions += [
+ '-Wno-bad-function-cast',
'-Wno-deprecated-declarations',
'-Wno-nonportable-system-include-path',
]