summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-09-08 11:50:48 -0400
committerDavid Robillard <d@drobilla.net>2022-09-08 11:50:48 -0400
commita0293511f4d82d7cb800f568ff5c0d82be5c40c7 (patch)
tree7b3dd1ec2eb72d90ed4fc195633ce6f662f43f5f /meson.build
parentafc6ef7e54988fd68f33df21ec2a220e6bfc49f4 (diff)
downloadzix-a0293511f4d82d7cb800f568ff5c0d82be5c40c7.tar.gz
zix-a0293511f4d82d7cb800f568ff5c0d82be5c40c7.tar.bz2
zix-a0293511f4d82d7cb800f568ff5c0d82be5c40c7.zip
Only run autoship and reuse tests in strict mode
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build34
1 files changed, 18 insertions, 16 deletions
diff --git a/meson.build b/meson.build
index d6b6ca7..21dd704 100644
--- a/meson.build
+++ b/meson.build
@@ -215,23 +215,25 @@ threaded_tests = [
]
if not get_option('tests').disabled() and not meson.is_subproject()
- # Check release metadata
- autoship = find_program('autoship', required: false)
- if autoship.found()
- test('autoship', autoship,
- args: ['test', meson.current_source_dir()],
- suite: 'data')
- endif
+ if get_option('strict')
+ # Check release metadata
+ autoship = find_program('autoship', required: get_option('tests'))
+ if autoship.found()
+ test('autoship', autoship,
+ args: ['test', meson.current_source_dir()],
+ suite: 'data')
+ endif
- # Check licensing metadata
- reuse = find_program('reuse', required: get_option('tests'))
- if reuse.found()
- test(
- 'REUSE',
- reuse,
- args: ['--root', meson.current_source_dir(), 'lint'],
- suite: 'data',
- )
+ # Check licensing metadata
+ reuse = find_program('reuse', required: get_option('tests'))
+ if reuse.found()
+ test(
+ 'REUSE',
+ reuse,
+ args: ['--root', meson.current_source_dir(), 'lint'],
+ suite: 'data',
+ )
+ endif
endif
common_test_sources = files('test/failing_allocator.c')