summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2021-09-10 20:11:34 -0400
committerDavid Robillard <d@drobilla.net>2021-09-10 20:11:34 -0400
commitbb9d3ce25dd09b96cdf232477c90414270c503e8 (patch)
tree0bd894b808e93e01bde94112925230188cf77ff4 /meson.build
parent129bcfb52322c2e27fc0e63605bc04c99ac40f8c (diff)
downloadzix-bb9d3ce25dd09b96cdf232477c90414270c503e8.tar.gz
zix-bb9d3ce25dd09b96cdf232477c90414270c503e8.tar.bz2
zix-bb9d3ce25dd09b96cdf232477c90414270c503e8.zip
Allow ZixBTreeIter to be allocated on the stack
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 8be6321..cdde084 100644
--- a/meson.build
+++ b/meson.build
@@ -54,7 +54,7 @@ if get_option('strict')
'-Wformat-signedness',
'-Wformat-truncation=2',
'-Wformat=2',
- '-Wframe-larger-than=512',
+ '-Wframe-larger-than=1024',
'-Wimplicit-fallthrough=2',
'-Winit-self',
# '-Winline',
@@ -74,7 +74,7 @@ if get_option('strict')
'-Wshift-overflow=2',
'-Wsizeof-array-argument',
'-Wstack-protector',
- '-Wstack-usage=512',
+ '-Wstack-usage=1024',
'-Wstrict-aliasing=3',
# '-Wstrict-overflow=5',
'-Wstringop-overflow=3',