summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-11-03 09:53:41 -0400
committerDavid Robillard <d@drobilla.net>2022-11-03 09:53:41 -0400
commitbd0105f64fb4ed62aae26be82d325ec70066886b (patch)
tree352627e0527a6c6d77d306dda319a23dde7e489f /meson.build
parent38ff3302e17320ad194964711fb1592dfe2af449 (diff)
downloadzix-bd0105f64fb4ed62aae26be82d325ec70066886b.tar.gz
zix-bd0105f64fb4ed62aae26be82d325ec70066886b.tar.bz2
zix-bd0105f64fb4ed62aae26be82d325ec70066886b.zip
Actually fix MacOS build
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index cc652e5..203605c 100644
--- a/meson.build
+++ b/meson.build
@@ -490,12 +490,20 @@ if not get_option('tests').disabled()
'-Wno-padded',
'-Wno-zero-as-null-pointer-constant',
]
+
+ if not meson.is_cross_build()
+ cpp_test_args += [
+ '-Wno-poison-system-directories',
+ ]
+ endif
+
elif cpp.get_id() == 'gcc'
cpp_test_args = [
'-Wall',
'-Wno-padded',
'-Wno-unused-const-variable',
]
+
elif cpp.get_id() == 'msvc'
cpp_test_args = [
'/Wall',