summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2021-09-10 22:36:10 -0400
committerDavid Robillard <d@drobilla.net>2021-09-10 22:44:50 -0400
commitbfaa6fbc6b2be3b23f4e4d268c5cbea8fb8ecf77 (patch)
treed66c5911a7fad97adef29065afbf10ed3e9a0ba1 /meson.build
parentf4e7e7116b0fcd104fa3859c92ec998468030ace (diff)
downloadzix-bfaa6fbc6b2be3b23f4e4d268c5cbea8fb8ecf77.tar.gz
zix-bfaa6fbc6b2be3b23f4e4d268c5cbea8fb8ecf77.tar.bz2
zix-bfaa6fbc6b2be3b23f4e4d268c5cbea8fb8ecf77.zip
Adopt REUSE machine-readable licensing standard
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index fb8e2a7..4f47b71 100644
--- a/meson.build
+++ b/meson.build
@@ -1,3 +1,6 @@
+# Copyright 2020-2021 David Robillard <d@drobilla.net>
+# SPDX-License-Identifier: CC0-1.0 OR ISC
+
project('zix', ['c'],
version: '0.0.3',
license: 'ISC',
@@ -240,6 +243,14 @@ tests = [
# Build and run tests
if get_option('tests')
+ # Check licensing metadata
+ reuse = find_program('reuse', required: false)
+ if reuse.found()
+ test('REUSE', reuse,
+ args: ['--root', meson.current_source_dir(), 'lint'],
+ suite: 'data')
+ endif
+
thread_dep = dependency('threads')
dl_dep = cc.find_library('dl', required: false)