summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-10-23 13:41:15 -0400
committerDavid Robillard <d@drobilla.net>2022-10-23 13:46:58 -0400
commitc886d489576cd0bc33d7d22d81981c794067946f (patch)
treef43c8d872401ed80b37f974516d9e9f2fee9d765 /meson.build
parentf95a698b94069ed03f6a8f2d0f7eb089d66c91ef (diff)
downloadzix-c886d489576cd0bc33d7d22d81981c794067946f.tar.gz
zix-c886d489576cd0bc33d7d22d81981c794067946f.tar.bz2
zix-c886d489576cd0bc33d7d22d81981c794067946f.zip
Add path API
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9a64ba6..bf082b9 100644
--- a/meson.build
+++ b/meson.build
@@ -9,6 +9,7 @@ project('zix', ['c'],
'b_ndebug=if-release',
'buildtype=release',
'c_std=c99',
+ 'cpp_std=c++17',
])
major_version = meson.project_version().split('.')[0]
@@ -100,6 +101,7 @@ c_headers = files(
'include/zix/digest.h',
'include/zix/function_types.h',
'include/zix/hash.h',
+ 'include/zix/path.h',
'include/zix/ring.h',
'include/zix/sem.h',
'include/zix/status.h',
@@ -117,6 +119,7 @@ sources = files(
'src/digest.c',
'src/errno_status.c',
'src/hash.c',
+ 'src/path.c',
'src/ring.c',
'src/status.c',
'src/string_view.c',
@@ -227,6 +230,7 @@ sequential_tests = [
'test_btree',
'test_digest',
'test_hash',
+ 'test_path',
'test_status',
'test_tree',
]
@@ -328,6 +332,22 @@ if not get_option('tests').disabled()
),
)
endif
+
+ if add_languages(['cpp'], native: false, required: get_option('tests_cpp'))
+ cpp = meson.get_compiler('cpp')
+
+ test(
+ 'test_path_std',
+ executable(
+ 'test_path_std',
+ files('test/cpp/test_path_std.cpp'),
+ cpp_args: program_c_args,
+ dependencies: [zix_dep],
+ include_directories: include_dirs,
+ link_args: program_link_args,
+ ),
+ )
+ endif
endif
##############