summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-05-02 18:30:35 -0400
committerDavid Robillard <d@drobilla.net>2023-05-02 18:30:35 -0400
commitf9f25a939106febafb238446429b18777f126cdd (patch)
tree7d1da45a712080c3cec4a865c504c18f91791a90 /meson.build
parentb4ef50c50590c273984d27f9c3a311e7ee8c0ce4 (diff)
downloadzix-f9f25a939106febafb238446429b18777f126cdd.tar.gz
zix-f9f25a939106febafb238446429b18777f126cdd.tar.bz2
zix-f9f25a939106febafb238446429b18777f126cdd.zip
Fix warning_level=everything on MacOS
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index e0c3ad9..fc687a0 100644
--- a/meson.build
+++ b/meson.build
@@ -50,6 +50,12 @@ if cc.get_id() in ['clang', 'emscripten']
'-Wno-padded',
]
+ if not meson.is_cross_build()
+ c_suppressions += [
+ '-Wno-poison-system-directories',
+ ]
+ endif
+
if host_machine.system() == 'windows'
c_suppressions += [
'-Wno-deprecated-declarations',