summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build31
1 files changed, 22 insertions, 9 deletions
diff --git a/meson.build b/meson.build
index 1ca5ec4..720bbca 100644
--- a/meson.build
+++ b/meson.build
@@ -444,6 +444,28 @@ if not get_option('benchmarks').disabled()
subdir('benchmark')
endif
+# Display top-level summary (augmented in subdirectories)
+if not meson.is_subproject()
+ summary(
+ {
+ 'Tests': not get_option('tests').disabled(),
+ 'Benchmarks': build_benchmarks,
+ },
+ bool_yn: true,
+ section: 'Configuration',
+ )
+
+ summary(
+ {
+ 'Install prefix': get_option('prefix'),
+ 'Headers': get_option('prefix') / get_option('includedir'),
+ 'Libraries': get_option('prefix') / get_option('libdir'),
+ },
+ bool_yn: true,
+ section: 'Directories',
+ )
+endif
+
#############################
# Scripts and Documentation #
#############################
@@ -453,12 +475,3 @@ subdir('scripts')
if not get_option('docs').disabled()
subdir('doc')
endif
-
-if not meson.is_subproject()
- summary('Benchmarks', build_benchmarks, bool_yn: true)
- summary('Tests', not get_option('tests').disabled(), bool_yn: true)
-
- summary('Install prefix', get_option('prefix'))
- summary('Headers', get_option('prefix') / get_option('includedir'))
- summary('Libraries', get_option('prefix') / get_option('libdir'))
-endif