summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index d7ba9d0..45009c4 100644
--- a/meson.build
+++ b/meson.build
@@ -66,7 +66,7 @@ if get_option('strict')
'-Wformat-signedness',
'-Wformat-truncation=2',
'-Wformat=2',
- '-Wframe-larger-than=1024',
+ '-Wframe-larger-than=2048',
'-Wimplicit-fallthrough=2',
'-Winit-self',
# '-Winline',
@@ -86,7 +86,7 @@ if get_option('strict')
'-Wshift-overflow=2',
'-Wsizeof-array-argument',
'-Wstack-protector',
- '-Wstack-usage=1024',
+ '-Wstack-usage=2048',
'-Wstrict-aliasing=3',
# '-Wstrict-overflow=5',
'-Wstringop-overflow=3',
@@ -184,6 +184,7 @@ sources = [
'src/allocator.c',
'src/bitset.c',
'src/btree.c',
+ 'src/bump_allocator.c',
'src/digest.c',
'src/hash.c',
'src/ring.c',