summaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/test/meson.build b/test/meson.build
index 193d898..15f449c 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -27,11 +27,13 @@ endif
# Set warning suppression flags specific to tests
test_suppressions = []
-if cc.get_id() in ['clang', 'emscripten']
- if host_machine.system() == 'windows'
+if host_machine.system() == 'windows'
+ if cc.get_id() in ['clang', 'emscripten']
test_suppressions += [
'-Wno-format-nonliteral',
]
+ elif cc.get_id() == 'gcc'
+ test_suppressions += ['-Wno-format']
endif
endif