summaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build39
1 files changed, 1 insertions, 38 deletions
diff --git a/test/meson.build b/test/meson.build
index 63141bb..32cc736 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -6,44 +6,7 @@
########
if get_option('lint')
- if not meson.is_subproject()
- # Check release metadata
- autoship = find_program('autoship', required: get_option('tests'))
- if autoship.found()
- test('autoship', autoship, args: ['test', zix_src_root], suite: 'data')
- endif
-
- # Check code with cppcheck
- cppcheck = find_program('cppcheck', required: false)
- if cppcheck.found()
- compdb_path = join_paths(zix_build_root, 'compile_commands.json')
- cppcheck_args = [
- '--enable=warning,style,performance,portability',
- '--error-exitcode=1',
- '--project=' + compdb_path,
- '--suppress=constParameterCallback',
- '--suppress=constParameterPointer',
- '--suppress=normalCheckLevelMaxBranches',
- '--suppress=unreadVariable',
- '-q',
- ]
- test('cppcheck', cppcheck, args: cppcheck_args, suite: 'code')
- endif
- endif
-
- # Check licensing metadata
- reuse = find_program('reuse', required: get_option('tests'))
- if reuse.found()
- reuse_args = ['--root', zix_src_root, 'lint']
- test('REUSE', reuse, args: reuse_args, suite: 'data')
- endif
-
- # Check code formatting
- clang_format = find_program('clang-format', required: false)
- if clang_format.found()
- clang_format_args = ['--Werror', '--dry-run'] + c_headers + sources
- test('format', clang_format, args: clang_format_args, suite: 'code')
- endif
+ subdir('lint')
endif
##############