summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Dröge <slomo@circular-chaos.org>2008-10-31 18:39:37 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2008-10-31 18:39:37 +0000
commit89b5a74b8677e0b58fea51941c7935a90ce8e987 (patch)
tree03d00e5c3d8281ac9f8751c8a2cdfa638d223511 /configure.ac
parenta1ed30d406a02035b20a3deb2ddd1f67d811f726 (diff)
downloadgst-plugins-bad-89b5a74b8677e0b58fea51941c7935a90ce8e987.tar.gz
gst-plugins-bad-89b5a74b8677e0b58fea51941c7935a90ce8e987.tar.bz2
gst-plugins-bad-89b5a74b8677e0b58fea51941c7935a90ce8e987.zip
configure.ac: Use AC_TRY_COMPILE instead of AC_TRY_RUN as the result of the linking is what is interesting, not that ...
Original commit message from CVS: * configure.ac: Use AC_TRY_COMPILE instead of AC_TRY_RUN as the result of the linking is what is interesting, not that it actually runs. Fixes cross-compilation and fixes bug #558639.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7c983ad9..732ae31d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -392,10 +392,11 @@ AG_GST_CHECK_FEATURE(APEXSINK, [AirPort Express Wireless sink], apexsink, [
# Basic test to check for compatible version and correct linking
# *does not* test for RSA - that comes later.
- AC_TRY_RUN(
+ AC_TRY_COMPILE(
[
#include <string.h>
#include <openssl/rand.h>
+],[
int main(void)
{
char a[2048];